macrakis at alum.mit.edu
Tue May 29 10:49:48 CDT 2007
On 5/29/07, van Nek <van.nek at arcor.de> wrote:
> Maybe 'parsenumber´ would be better, maybe 'parsetoken´ is appropriate,
> because it
> tokenizes the 2 from 2 / 3, just as a warning.
I agree, the 2/3 case is debatable, but the routine's general functionality
remains parsing a number, not a token in general, so I believe the name
should be changed to reflect this.
I have just committed a new version, which can parse bigfloats using the
> (mread). Integers, floats and rationals are still parsed first only by the
> Lisp-reader (read),
> so that the speed advantage still remains.
Great! I was too lazy to do this...
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the Maxima