[Maxima] proposed changes for fft stuff
robert.dodier at gmail.com
Fri Jul 10 10:18:12 CDT 2009
On 7/10/09, Raymond Toy <raymond.toy at stericsson.com> wrote:
> Have we agreed on fft_inverse previously?
I went back & looked at the email archive. When I brought it up
before, a few people liked fft_inverse and a few liked ifft.
One liked inverse_fft.
> I'm partial to ifft. Matlab and octave use this. And you can still find
> it using ?? fft.
I'm pretty much opposed to ifft at this point. Naming it the same
seems pointless given all the other differences with Matlab/Octave,
notably the definition of the transform differs with Octave
(normalization is different). Wouldn't be surprised if Matlab is
Cryptic abbreviations are OK for frequently-used functions,
but Maxima has a very large namespace and most functions
are never used by most people. Given that, it is more important
to give it a descriptive name.
I';m partial to big-endian names but inverse_fft is OK too.
(I see there are already inverse_jacobi_foo functions.
We talked about renaming ilt to inverse_laplace but it
More information about the Maxima