smh at franz.com
Wed Sep 9 11:54:06 CDT 2009
Robert Dodier <robert.dodier at gmail.com> wrote:
I;m in favor of changing all existing SLOOP to LOOP.
Leave the macro definition as it stands just in case someone
is using SLOOP in their own code.
I suggest leaving the macro, but have it warn at macroexpand time that
sloop has been replaced by the standard loop and code calls to sloop
should be replaced with loop.
That will encourage updating any code that still uses sloop, and perhaps
it can be removed entirely some day. This little historical appendices
are not completely cost free -- consider how much developer time it has
consumed over the past few days.
Even if the sloop macro is not removed, the warning will serve as
documentation what sloop was, and that it shouldn't be used in code.
More information about the Maxima